Ongoing investigations indicate that there might be minor limitations in the DE system, which may likewise affect Staffbase Email. We’ll continue to keep you updated as we learn more.
We’re sorry for the disruption. If you have any questions in the meantime, please feel free to reach out to us at support@staffbase.com.
Posted Nov 18, 2025 - 10:27 CET
Update
The issue has recurred and persists. We have escalated the investigation to the highest priority, requiring direct and immediate involvement from our dedicated Infrastructure team to resolve the underlying cause.
Posted Nov 18, 2025 - 06:02 CET
Monitoring
We have increased resources to resolve the issue and media files should be loading again. We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Nov 17, 2025 - 17:20 CET
Investigating
We have received reports that some media files are currently not loaded on the US system. Our teams are investigating the behavior and will work to resolve this as quickly as possible. We will share more information soon.
You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.
We apologize for the inconvenience this may cause. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Nov 17, 2025 - 13:15 CET
This incident affects: App, Intranet & Staffbase Email (Media API (Americas) [SLA]).