[App/Intranet/Email] [German System] - App is loading very slowly

Incident Report for Staffbase

Resolved

The issue is resolved. We apologize for the inconvenience this has caused.

Please get in touch with us at support@staffbase.com in case you're still having any problems. We’re happy to help!
Posted Sep 04, 2025 - 16:59 CEST

Monitoring

We have taken steps to improve the situation, and the app is currently loading normal again. Our teams will continue to monitor the system to ensure that everything remains stable.

If you experience any further issues or have questions, please contact our support at support@staffbase.com.
Posted Sep 04, 2025 - 15:38 CEST

Investigating

Affected feature: App/Intranet

We have received reports that the app is currently loading very slowly for some customers on the German system. Our teams are investigating the behavior and will work to resolve this as quickly as possible. We will share more information soon.
You can see on which system your application is hosted by going to the Studio > Settings > API Access and checking the tag next to the title.

We apologize for the inconvenience this may cause. If you have any questions regarding this topic, please reach out to our support at support@staffbase.com.
Posted Sep 04, 2025 - 15:04 CEST
This incident affected: App, Intranet & Staffbase Email (Core API (Europe) [SLA], Web Application (Europe) [SLA]).