Studio Email, new drafts not appearing in Drafts list (US environment)

Incident Report for Staffbase

Monitoring

We have deployed a fix to resolve the issue affecting new Studio Email drafts in our US environment. Creating and viewing new drafts and templates should now work as expected.
We will continue to monitor the systems until we are sure the issue is fully resolved.
Posted Jul 09, 2026 - 16:19 CEST

Investigating

We are investigating an issue affecting the creation of new Studio Email drafts and templates in our US environment. When creating a new draft, you may see a successful save confirmation, but the draft does not appear in your Drafts list afterward.
Existing drafts and previously sent emails are not affected. Customers hosted in our EU environment are not affected.
Our team is actively working to identify and resolve the cause. We will post an update as soon as we have more information.
Posted Jul 09, 2026 - 16:01 CEST
This incident affects: App/Intranet/Email (Web App (Americas) [SLA]).