[Europe System | Americas System] [Email Modern] - Drafts failing to load in Email Modern

Incident Report for Staffbase

Postmortem

Summary — On June 18, between 8:56 PM and 12:24 PM (CEST), customers across all systems encountered issues accessing pre-existing email drafts, or experienced unresponsiveness when interacting with certain elements in drafts in Staffbase Email Modern. Our teams successfully identified the cause and restored full service functionality.

What Happened — A recent update introduced a change to the email editing component that affected how certain draft content was processed. Some drafts failed to open and displayed an error message, while others contained elements that caused the page to become unresponsive when accessed. Our team identified and resolved the issue, restoring normal access to all affected drafts.

Impact — Between 8:56 PM and 12:24 PM (CEST) on June 18, users with certain pre-existing email drafts may have experienced an error message when attempting to open those drafts, or found the page unresponsive. Drafts without the affected content continued to work normally.

Future Improvements — We will implement additional checks for the operation of the affected service component and improve our ability to detect and resolve similar issues more quickly in the future.

Thank you for your patience and understanding while we work to improve our services and prevent future incidents.

If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.

Posted Jun 24, 2026 - 17:06 CEST

Resolved

We have deployed a fix for the errors affecting drafts in the Email Modern environment. All systems are operating normally.

We apologize for any inconvenience this may have caused. If you continue to experience issues loading or editing drafts, please contact our support team at support@staffbase.com.
Posted Jun 19, 2026 - 00:25 CEST

Identified

We have identified the cause of the issues affecting drafts in Email Modern on the Americas system. Our teams are actively working to implement a fix and restore full functionality.

We will provide a further update as soon as the fix is in place.

If you have any questions, please reach out to our support team at support@staffbase.com.
Posted Jun 18, 2026 - 23:02 CEST

Investigating

We have received reports that some customers on the Americas system are experiencing an error when attempting to open pre-existing drafts in Email Modern, or drafts stop responding

Our teams are currently investigating the root cause. You can see on which system your application is hosted by going to Studio > Settings > API Access tab.

We apologize for the inconvenience. If you have any questions, please reach out to our support team at support@staffbase.com.
Posted Jun 18, 2026 - 22:03 CEST
This incident affected: App, Intranet & Staffbase Email (Staffbase Email API (Americas), Staffbase Email API (Europe)).