[Europe System | Americas System] [Email Modern] – Degraded performance in Email Modern

Incident Report for Staffbase

Postmortem

Summary — On June 18, between 6:33 PM and 7:08 PM (CEST), customers on the European System and Americas System experienced an inability to view email analytics, audience data, and click maps in Staffbase Employee Email. Our teams successfully identified the cause and restored full service functionality.

What Happened — A recent update to Staffbase Employee Email introduced an issue that caused analytics and sent email data to fail loading. This affected the analytics overview, audience data, click maps, and the details panel within individual sent emails. Our team identified the cause, reverted the recent update, and confirmed that all affected data was loading as expected following the fix.

Impact — Between approximately 6:33 PM and 7:08 PM (CEST), users on the European System and Americas System were unable to view email statistics, audience data, and click maps in Staffbase Employee Email. In some cases, data either failed to load or took several minutes to appear, making the analytics workflow effectively unavailable during this period.

Future Improvements — We will implement additional checks for the operation of the affected service component and improve our ability to detect and resolve similar issues more quickly in the future.

Thank you for your patience and understanding while we work to improve our services and prevent future incidents.

If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.

Posted Jun 23, 2026 - 15:29 CEST

Resolved

The issues affecting email analytics have been resolved. All systems are now operating normally.

We apologize for any inconvenience this may have caused. If you are still experiencing issues, please reach out to our support team at support@staffbase.com.
Posted Jun 18, 2026 - 21:18 CEST

Monitoring

All systems are back up and operational.

Our teams are continuing to investigate the underlying cause and are actively monitoring all systems to ensure stability.

We apologize for any inconvenience this may have caused. If you are still experiencing issues, please reach out to our support team at support@staffbase.com.
Posted Jun 18, 2026 - 19:22 CEST

Update

We are continuing to investigate this issue.
Posted Jun 18, 2026 - 19:07 CEST

Investigating

We have received reports that some customers on the European and Americas systems are experiencing issues with email analytics failing to load. Affected areas include sent email statistics, audience data, and email designer.

You can see on which system your application is hosted by going to Studio > Settings > API Access tab. Our teams are actively investigating the issue. We will provide a further update as soon as we have more information.

We apologize for the inconvenience. If you have any questions, please reach out to our support team at support@staffbase.com.
Posted Jun 18, 2026 - 18:30 CEST
This incident affected: App, Intranet & Staffbase Email (Staffbase Email API (Americas), Staffbase Email API (Europe)).