[Global] [App/Intranet] – New SSO users not assigned to Conditional Groups upon account creation

Incident Report for Staffbase

Postmortem

Summary
As our investigation is now complete, we would like to provide details about an issue where new users created via SSO were not automatically assigned to their Conditional Groups. The incident was initially assessed as potentially affecting all systems. Following our investigation, we confirmed that only the European System was impacted. Our team identified the root cause, deployed a fix on June 2, 2026, and confirmed full resolution on June 3, 2026.

What Happened
Following a recent update, the process responsible for assigning users to Conditional Groups based on their profile attributes was not triggered correctly during SSO account creation. New users were created successfully and their profile information was transferred, but the subsequent group assignment step was silently skipped. Our team identified the issue and implemented a fix that restored the correct behavior for new SSO user accounts.

Impact
New users created via SSO on the European System were not automatically assigned to their Conditional Groups at account creation. Affected users did not receive the expected group memberships and required manual profile updates to trigger the assignment until the fix was applied. No impact was observed on the Americas System or the Asia/Pacific System. The fix was deployed on June 2, 2026, and confirmed fully effective on June 3, 2026.

Future Improvements
We will implement additional checks for the operation of the affected service component and improve our ability to detect and resolve similar issues more quickly in the future.

Thank you for your patience and understanding while we work to improve our services and prevent future incidents.

If you have any questions or concerns, please do not hesitate to reach out to our customer support team at support@staffbase.com.

Posted Jun 05, 2026 - 11:43 CEST

Resolved

The issue affecting Conditional Group assignments for new users created via SSO has been resolved. New users are now automatically assigned to the correct Conditional Groups based on their profile field values upon account creation.
We apologize for any inconvenience this may have caused. If you are still experiencing issues, please reach out to our support team at support@staffbase.com.
Posted Jun 03, 2026 - 15:07 CEST

Monitoring

We have taken measures to address the issue affecting Conditional Group assignment for new SSO users, and the fix is now being rolled out across all systems.
We will continue to monitor the situation closely to ensure new users are assigned to their Conditional Groups correctly upon account creation.
If you continue to experience this issue, please contact our support team at support@staffbase.com.
Posted Jun 02, 2026 - 17:34 CEST

Investigating

Affected feature: User Provisioning / Conditional Groups

We have received reports that new users onboarded via Single Sign-On (SSO) are not being automatically assigned to their Conditional Groups at the time of account creation.
Profile field values are transferred correctly during provisioning. However, the group assignment does not take effect until a profile field is manually updated afterward. Our teams are currently investigating the issue.

We apologize for the inconvenience. If you have any questions regarding this topic, please reach out to our support team at support@staffbase.com.
Posted Jun 02, 2026 - 16:14 CEST
This incident affected: App, Intranet & Staffbase Email (Core API (Americas) [SLA], Core API (Europe) [SLA], Core API (Asia/Pacific) [SLA]).